miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
Official Addons and Solutions miniBB Support Forums / Official Addons and Solutions /   

Mobile version

Page  Page 2 of 3:  « Previous  1  2  3  Next »  
Author Rider
Registered
#16 | Posted: 5 Jan 2015 22:00 
I'm half way installing the mobile premium pack. I created a subdomain, which points to the main forum directory. When I visit the url m.mydomain.com on my telephone the 'Mobile Version' link shows up nicely in main_footer, on my Mac it doesn't. The main forum is shown. That's all according to specs. So far so good.

But when I click on the link to be redirected to the mobile forum, nothing happens, it only reloades the current page (the main forum). Of course I have the mobile templates installed under their default names and folder.

I'm sure I did something wrong, so I am going to re-read the tutorial. But in the meantime I have a feeling that I am missing something, because I can't find the place where the mobile template foldername is used. I know the foldername is set in setup_options.php (in $pathToTpl), but I can't find that variable being used anywhere else. Well, in index.php it is used once, but only in $unset (it's a sort of initializing procedure?). Who knows this might be the cause of my problem?

(But no, the cause is probably me, myself and I;-))

Author Rider
Registered
#17 | Posted: 6 Jan 2015 20:46 
Sorry for asking, but in the tutorial it says:
"The code below of it sets up the 'mobile' mode for the 'mobile' sub-domain, i.e. it defines the MOBILE constant, which is very important for all miniBB scripts"

I am asking myself: below of where? I assume there should be some code below '$mobileUrl='http://'.$mobileHost;' in the green textbox, but there is nothing below there.

Author Paul
Lead Developer
#18 | Posted: 7 Jan 2015 19:02 
Sorry, it seems there is truly something missing in the tutorial. I must be back at 9th, right now I don't have ftp access to check for the exact code. But there should be something like

If($is_mobile_test or $is_mobile_browser) define(MOBILE,1);


Author Rider
Registered
#19 | Posted: 7 Jan 2015 21:29 
This line of code takes me right to the "mobile version", that's a big step forward, thanks.

But now the main forum page is shown without graphical layout. It looks as if the mobile stylesheet can't be found. At this point I'll wait until you have found out if there are more lines of code missing in the tutorial.

But I am almost 100% sure that there is (also) something wrong on my side. Because clicking on a hyperlink (the url is like http://m.mydomain.com/index.php?action=vthread&forum=2&topic=12345) on the main forum page results in a 404: "The requested URL /index.php was not found on this server". Above that my Safari browser keeps showing 'm.mydomain.com' in the address bar where Firefox shows the address to where is redirected, i.e. 'www.mydomain.com/phpdata/forums'. This makes me think there is something wrong in my domain settings but I don't know if that interferes with the above problem.

Author Paul
Lead Developer
#20 | Posted: 8 Jan 2015 11:25 
You may check the source of html page and look in which address it takes pointing to css file.

Also, you must configure the sub-domain, so it is not being redirected. It should just have the same path as the root domain, and open your root forum by default is mobile config is not set. That's very simple to test.

Author Rider
Registered
#21 | Posted: 9 Jan 2015 11:04 
Wonderful, it's working like a charm now.

There was something wrong with the host settings indeed. When I first tried the "website" type subdomain in Plesk it didn't function as I wanted, so I switched to the "Forward" type, which resulted in the above mentioned problems. But now with a few changes in the "website" type, it's working after all.

Now let's go mobile:-) Thanks for your help.

Author Rider
Registered
#22 | Posted: 10 Jan 2015 00:07 
I'm still not quite there. I let the premium version rest for a while and am now trying to get the free version fully functional.

The problem:
With cleared cache and cookies, my mobile phone still takes me right to the mobile version, while there should not be an 'automated redirection to the Mobile version' according to the tutorial. Above that the link 'Full version' doesn't work. I can't get from the mobile to the full version on my phone now.

Two questions:
The tutorial says 'Besides of it, this code will set a cookie named 'mobile2full''. I don't know which code is meant, but I don't see it in the green textbox. I know there is something about cookies in bb_plugins.code.txt, but following the tutorial literally I am under the impression that the green textbox in the tutorial is meant here. What's missing, or am I wrong?

Then a bit further down it says 'The package of the mobile pack you've got, contains the file called bb_plugins.code.txt.' and something about /* Mobile Link */ and /* Mobile version */ . But when I look into bb_plugins.code.txt there is only /* Mobile version */. The other is missing. What's missing, or am I wrong?

Me, trying to be clever, I took the /* Mobile Link */ code from my premium pack and added it. But that doesn't solve my problem.

That's about it. Hope you can help.

Thanks. BTW: the mobile version on its own works great!

Author Paul
Lead Developer
#23 | Posted: 15 Jan 2015 14:02 
Sorry for late response - I've checked my codes and it seems there is really some mess with them. I hope to come up with the proper solution later today or tomorrow. One question though - is the Mobile version of miniBB forums works properly for you? It is the Premium version, i.e. that one which should redirect properly for advanced URLs as well, and it should switch properly back and forth from/to the full version. Let me know if it works for you. Thanks and sorries for delay with this.

Author Rider
Registered
#24 | Posted: 15 Jan 2015 15:51 
No problem, take your time. I won't be active on my forum today and tomorrow.

Sorry I don't have an answer to your question. I've been trying to get the free version to work properly. At this moment I can't break out of the mobile version at all, so it's hard to tell, if not impossible, if the premium part of the code is working properly.

Thanks

Author Paul
Lead Developer
#25 | Posted: 15 Jan 2015 17:32 
I was meaning minibb forums. HERE :) our forums. They also have a mobile version. Could you check it on your device? Is switching working properly for that? Thanks.

Author Rider
Registered
#26 | Posted: 15 Jan 2015 20:24 
Lol, ok:-) I ran some tests. Here's how it works on my Android 4.4.4 phone, with cleared cache and cookies:

Linking in general
I type m.minibb.com. I am brought straight to the mobile forums.
I click on [page 2] of this topic in the topic list. Page 2 (mobile) is shown.
I add page 2 to my Android bookmarks.
I visit some other website and after that, via the bookmarks list, go back to the Page 2. Page 2 (mobile) is shown.

Hyperlink to [full version] vice versa, again with with cleared cache and cookies:
I type m.minibb.com. I am brought straight to the mobile forums.
I click on the hyperlink to [full version]. I am brought to the full forum. In the address bar it changes into www.minibb.com/forums/
On the full forum I see the hyperlink [Mobile version]. Clicking it brings me back to the mobile forums.
I visit [page 2] of this topic. It is possible to switch between the [mobile version] and [full version], page 2 is shown all the time.

Conclusion
One thing is different from what's mentioned in the tutorial: when I type m.minibb.com I am always brought to the mobile forum. Even though my last visit was to the full forum (during this test I didn't clear the cache or cookies).
The rest works fine.

Author Paul
Lead Developer
#27 | Posted: 17 Jan 2015 17:29 | Edited by: Paul 
Thanks for testing!

Rider:
when I type m.minibb.com I am always brought to the mobile forum

Hmm, where did you find contradiction with manual regarding this? It seems it should work the way like you describe. So it's all looks OK - you should stay on the Mobile version until you switch to the Full version, clicking the link on top. It SHOULD work like this. So whenever you enter miniBB forums (or any other forums) with a mobile device, you're forced to the latest choice you've made - either clicked the "Mobile version", and so you stay on the Mobile version; or you did not click it, or clicked "Full Version", so anytime the Full version will be opened.

I'll try to compile the version I have on our forums and publish it soon. Looks like I would need to have just a Premium version of this add-on. Supporting two versions is too difficult :)

I'll post here when I'm ready.

Author Rider
Registered
#28 | Posted: 17 Jan 2015 18:55 
You're welcome.

Here's the contradiction. The manual says the following:
'By default, when entering a forum with the mobile device, there is no automated redirection to the Mobile version.'
Whichever the outcome will be, both solutions will be fine by me.

Good luck on fixing this, I appreciate it.

Author Paul
Lead Developer
#29 | Posted: 17 Jan 2015 18:57 | Edited by: Paul 
Rider:
'By default, when entering a forum with the mobile device, there is no automated redirection to the Mobile version.'

Ok, I think it misses just one word - I was meaning, a default forum :) I.e. when you enter Default forum (Full version), it won't redirect you automatically to the Mobile domain. I've fixed that so far and I am truly thinking off the possibility of drop the support of the free version. But I hope you have the Premium one, so you'll be able to update your package from the Customers area soon.

Thanks for all so far!

Author Jaime
Registered
#30 | Posted: 30 Jan 2015 14:55 
And now my mobile version is up to date. However, I have this enabled only for me. But it looks like everything is working as it should. So my updates are completed, MiniBB incl. all expansions (and i have all :)), up to date. Feels good ;-)

Page  Page 2 of 3:  « Previous  1  2  3  Next » 
Official Addons and Solutions miniBB Support Forums / Official Addons and Solutions / Mobile version Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
 
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Install the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB