miniBB ® 

miniBB

®
Support Forums
  
 | Start | Register | Search | Statistics | File Bank | Manual |
Specific miniBB Support Forums / Specific /   
 

Compiler not working correctly?

 
 
Page  Page 1 of 3:  1  2  3  Next »

Author Steve Shaw
Partaker
#1 | Posted: 27 Aug 2020 19:28 
I have tried to use the 'Compiler' to update our forum, but it doesn't seem to be working correctly...
It seems it is missing some paid options.

It warms me some have not been purchased, but is just missing others that have been paid for.

And now I'm struggling to get things working correctly...

Steve

Author Paul
Lead Developer
#2 | Posted: 27 Aug 2020 19:37 | Edited: Paul 
Steve Shaw
Could you please mention exactly what is not working? What add-on, option?.. Screenshots are appreciated.

Make sure you are logged-in to the Customers area before you are trying to compile the Premium stuff.

Author Steve Shaw
Partaker
#3 | Posted: 27 Aug 2020 19:43 
Here is the existing forum: (...)

And the new version being tested: (...)

The new forums is missing things like Premoderation/Private Messages/File Bank/File Upload/Images & Gallery/Polls/Surveys...

The existing version was made via the 'Compiler' about a year ago, and worked fine (with a couple of hiccups I reported back then).

Steve

Author Steve Shaw
Partaker
#4 | Posted: 28 Aug 2020 12:08 
I've been through everything again, and it really seems its not working... but it's using-up my paid-for downloads.
Any help appreciated.

Steve

Author Steve Shaw
Partaker
#5 | Posted: 30 Aug 2020 18:32 
I just purchased the 'Forums Checker add-on', as I wondered if that may 'kick' the Compiler into working correctly...
But, the Compiler still thinks I have not yet purchased the Forums Checker add-on.

Steve

Author Paul
Lead Developer
#6 | Posted: 31 Aug 2020 11:23 
Steve Shaw
I have to know what happens with your Compiler package, and the process you complete before you get to the compilation form. What you have on your domains, doesn't truly matter in this issue.

So — once again to repeat — here are the steps I've completed and successfully compiled the package with all allowed add-ons installed:

Logged in as the customer to the Customer's area URL, which you've received via email after your Order has been completed. You should complete this first. The system should recognize you as the Customer.

— Went to the Compiler form.

— Checked allowed packages to build-in and successfully finished the Compilation, clicking the button below the form and downloading via suggested link.

After compilation, at first check the package you download — what's inside? Do you see the files coming from Premium add-ons in bb_plugins.php, over the package folder? What's mentioned in README.txt file? It should be different from the default, which proves the compilation worked.

I've checked the issue with your Favorites add-on and now it should embed properly. Please check on your side.

Author Steve Shaw
Partaker
#7 | Posted: 31 Aug 2020 12:10 
Hi Paul,

I am using the process you have outlined:

— Logged in as 'Customer', which works, and I see the packages and support I have paid for.

— Go to the Compiler form, and select 'All', and configure any changes.

— Download the final Complie .zip file.

This is the same procedure I have used each time.

But, this time the new 'Forums Checker add-on' I purchased yesterday is seen, and the Compile looks correct...
So, whatever the issue was, it seems to have been fixed...
Now testing fully.

Steve

Author Paul
Lead Developer
#8 | Posted: 31 Aug 2020 14:56 
Steve Shaw
Ok, let me know how the testing went. I suppose, the problem was only about your recent purchase, as it was related to the recently updated ordering routines we use. Apologies for this issue.

Author Steve Shaw
Partaker
#9 | Posted: 31 Aug 2020 15:50 
I'm getting there... slowly.

Seem that the 'File Bank add-on' is not included in the Compiler.
Is that deliberate?

Steve

Author Paul
Lead Developer
#10 | Posted: 31 Aug 2020 16:01 
Steve Shaw:
Seem that the 'File Bank add-on' is not included in the Compiler.
Is that deliberate?

Yes. This add-on comes with a customization of physical folders, a lot of customizable file security settings, and it is only for experienced maintainers.

Author Steve Shaw
Partaker
#11 | Posted: 31 Aug 2020 16:03 
Ok — I have used 'File Bank/Storage' in the past, so will add manually.
Are there other options that are not configured via the 'Compiler'?

Steve

Author Paul
Lead Developer
#12 | Posted: 31 Aug 2020 16:27 
Steve Shaw:
Are there other options that are not configured via the 'Compiler'?

Lots of them, specially various customizations and specific solutions :-)

Compiler includes only the major basic stuff.

Author Steve Shaw
Partaker
#13 | Posted: 1 Sep 2020 12:28 
Hi Paul — still struggling to get all working again — and yes, it's all my fault...

Anyway, should the SQL User DB match the arrays in the PHP setup_options?

SQL

PHP

I seem to have some differences...

Steve

Author Steve Shaw
Partaker
#14 | Posted: 1 Sep 2020 12:30 
Mmmm — and I tried to edit out the [hl][/hl] code entered by mistake, and get this error message...

Wham!.. You are trying to make a step which is wrong. If you are sure this is a mistake, contact the Forums Administrator.

Just for feedback.

Steve

Author Paul
Lead Developer
#15 | Posted: 1 Sep 2020 13:07 | Edited: Paul 
Steve Shaw:
should the SQL User DB match the arrays in the PHP setup_options

No, the DB structure in PHPMyAdmin you see, should not match the numerical indexes. The indexes in $dbUserSheme are determined using the Determine Fields script.

Actually in miniBB they all start from 0 (zero); various DB tools list them starting from 1 (one).

Page  Page 1 of 3:  1  2  3  Next » 
Specific miniBB Support Forums / Specific /
 Compiler not working correctly?
 Share Topic's Link

Your Reply Click this icon to move up to the quoted message


 ?
Post as a Guest, leaving the Password field blank. You could also enter a Guest name, if it's not taken by a member yet. Sign-in and post at once, or just sign-in, bypassing the message's text.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.

 

 
 
miniBB Support Forums Powered by Forum Software miniBB ® Home  Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contact Us
Check out the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
 ⇑