miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
Specific miniBB Support Forums / Specific /   

No Button "Quote" after updating to Minibb 2.4

Page  Page 1 of 2:  1  2  Next »  
Author heldt
Registered
#1 | Posted: 2 Sep 2009 09:45 
Hey,
I come from Germany and my English isn't the best, but I hope you understand my problem ;-)
After I upgraded to version 2.4 there is no button "Quote"! The new function, that you see the user profile after press the username in a post works very good. Sure I can quote a user after I wrote the bbcode, but on the right of the post from the other user, there isn't the quote button anymore.
Thanks for your help
heldt

Author Paul
Lead Developer
#2 | Posted: 2 Sep 2009 10:42 
Try to analyze your JavaScript error console. In Mozilla Firefox, it is under Tools - Error Console.

Without seeing your website it's impossible to determine where the mistake may come from...

Author heldt
Registered
#3 | Posted: 3 Sep 2009 12:43 
The Error Console says:
ReferenceError: Can't find variable: getQuotation index.php:38

I can't find the problem!
My Forum: http://www.filmgruppe-bi.bplaced.net/Forum/

Author Paul
Lead Developer
#4 | Posted: 4 Sep 2009 04:07 
I've checked your templates/main_posts.html file and I'm not sure - why does it not have newlines, like in the default miniBB template? Sometimes JavaScript could be interpreted incorrectly when the newlines are missing.

It specially may affect tags like

<!--
...
//-->

they must be separated by newlines, in your version they are not...

Author heldt
Registered
#5 | Posted: 4 Sep 2009 09:38 
I get minibb 2.4 again from minibb.com and load up the main_posts.html to my Forum and there's still no Quote Button. I opened the file with Adobe Dreamweaver an it says: "Syntaxerror in line 21" My line 21 is: var displayQuote={$displayQuote};
But where's the problem and why says dreamweaver there's an error in the original file from your website?

Author Paul
Lead Developer
#6 | Posted: 7 Sep 2009 04:31 
Dreamweaver tries to interpret this file as it would be standalone (it "thinks" {$displayQuote} is the final value for the variable). But it's not the reason for your error.

I've checked your forums and I still see that the http://www.filmgruppe-bi.bplaced.net/Forum/templates/main_posts.html file still has no newlines.

Which mode are you uploading your files in? It should be ASCII mode, not the binary mode.
What FTP client are you using? Isn't it CuteFTP? ;-)

Author heldt
Registered
#7 | Posted: 7 Sep 2009 10:52 
It's FileZilla. The mode was: Automatic, I edited the option to ASCII an I load all files up again. But there's still no Quote Button. I copied the main_posts.html code with Notepad2 and I think it's a good editor.
Oh, I just tried another thing: I load up the original file from your Website into my Forums directory and now there's the Quote Button. But why does it now work? I think there's a problem with Notepad2. Have you got another editor or a reason why Notepad2 deletes the newlines?
And there's still another problem: There's no Button "Send Topic". I don't find the file, where the Button is wrote in. Maybe there's again a preoblem with the Newlines.
Thank you

Author Paul
Lead Developer
#8 | Posted: 7 Sep 2009 13:23 
miniBB is actually all composed in Notepad2. It's the best editor I've ever seen.

It may be FileZilla bug or "feature" actually. It may compress ASCII files on upload. Try Total Commander's FTP client.

The file you've got from here includes many stuff you don't need at all, because you don't have such add-ons.

Do not apply any changes to this file, just take it from Downloads package and without modifying it, put under your forums template. Do not open it in any editor. Will you see the Quote link?

If not, it's Filezilla's problem.

About Submit button... it is not appearing because it's called through JavaScript. Again, JavaScript doesn't work, because the file appears to be compressed: http://www.filmgruppe-bi.bplaced.net/Forum/templates/main_topics.html

Author heldt
Registered
#9 | Posted: 8 Sep 2009 08:57 
When I upload the file from your website without opening in an editor, there's the Quote Button. It's the same with the Submit Button, I load up main_topics.html and all works! But where's the problem. I would like to edit the code, but I can't do it, if there're problems with the newlines.

Author Paul
Lead Developer
#10 | Posted: 8 Sep 2009 13:01 
The files on miniBB.com forums are fully identical to the files we have under the default package. Well, may be in some non-critical aspects they differ, because we are using some specific add-ons. But definitely, they come with the same type of newlines (CR+LN - Windows).

Maybe it's unzipping problem?

After you download and unzip the files, and then edit them with Notepad2, do you see the proper newlines? Here is what I have in my Notepad2 when I edit the file:

main_topics.html template in Notepad2 (Newlines)

Author heldt
Registered
#11 | Posted: 9 Sep 2009 08:05 
it looks exactly like yours! After I edited a bit there are still the newlines! Notepad doesn't edit something by itself!

Author Paul
Lead Developer
#12 | Posted: 9 Sep 2009 09:24 | Edited by: Paul 
Ok then you need to get the point why the newlines disappear on the host itself... I'm not the wizard to determine it remotely :)

Also make sure to re-open the file after editing in Notepad2. Maybe you see the newlines after you have modified it, but they disappear on saving... who knows...

Author heldt
Registered
#13 | Posted: 9 Sep 2009 09:37 
the newlines are still there after edit, save, exit and reopen! It's very curious!

Author Paul
Lead Developer
#14 | Posted: 9 Sep 2009 09:50 
Ok, then it happens via upload on the server, what else?

Try another FTP uploader, I already suggested that... Total Commander is the best in my opinion (not only for file uploads, but also for the common file management - very comfortable and almost freeware tool!)

Author heldt
Registered
#15 | Posted: 10 Sep 2009 12:00 
I use Free Commander, it's the same, but Freeware. I tried it and it works. But now I think this isn't the problem, because it works too, after I uploaded the orginal files from the download package without opening in Notepad2 with FileZilla.
I think this is the problem: I've copied the new code over the old code in the old file and saved it. When I copy the new code in a new file and add the old lines into it, it works. Can this be the reason for the missing newlines?

Page  Page 1 of 2:  1  2  Next » 
Specific miniBB Support Forums / Specific / No Button "Quote" after updating to Minibb 2.4 Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
 
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Check out the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB