miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
How To miniBB Support Forums / How To /   

How did "Team" get his/her cool.gif?

Page  Page 1 of 2:  1  2  Next »  
Author MarcDK
Registered
#1 | Posted: 27 Mar 2003 21:09 
Hey, I want a picture for the miniBB admin in my board, too.

How does it work, team?

I also want the cool.gif :)
COOL

Author 4days
Champi0n
#2 | Posted: 27 Mar 2003 21:43 
..like this

if you're using IE then - - right-click, 'Save Picture As..'

Author MarcDK
Registered
#3 | Posted: 27 Mar 2003 22:09 
Mhhh, I don't exactly get the point. How should I use the userrankings to show the picture? Sorry... :(

Author 4days
Champi0n
#4 | Posted: 27 Mar 2003 23:50 | Edited by: 4days 
you're using the $userRanks array to allocate a specific string based on the users id - which could look something like this:

$userRanks=array(1=>'Team', 2=>'Joe User');

but if you wanted it to display an image instead of the string 'Team' whenever a post was made by user id 1 then you'd do something like this:

$userRanks=array(1=>'<img src="http://www.minibb.com/forums/img/smilies/cool.gif" alt="Team">', 2=>'Joe User');

i can't remember off the top of my head if you'd need to escape any of those speech marks in the string with \'s. haven't done any php in ages.

Author Team
8-)
#5 | Posted: 28 Mar 2003 09:38 
I guess, this is not really necessary to point to our board :) You can set it up like this way, for example:

$userRanks=array(1=>'<img src="./img/smilies/cool.gif" width=15 height=15 border=0>');

Author 4days
Champi0n
#6 | Posted: 28 Mar 2003 12:04 
sorry, overdid it on the copy and paste :)

Author TinnyFusion
Registered
#7 | Posted: 10 Oct 2003 23:58 | Edited by: TinnyFusion 
Hi there, I have updated my bb_specials.php page to have the following:

<?php
$clForums=array();
$roForums=array();
$poForums=array();
$userRanks=array(1=>'<img src="http://my_URL.com/forums/img/avatar.jpg" width=75 height=75 border=0>');
$userRanks=array();
$regUsrForums=array();
$mods=array();
?>

But it does not show my avatar...

Might this be related to another issue I have been having where when a user tried to register they get this error message:
Error in user data: Unable to register new user. Possibly username or email already taken, or admininistrator info isn`t filled, yet.

Can someone please advise me on how to set my user to ID=1 as I am a little confused.

Thank you, TinnyFusion

Author 4days
Champi0n
#8 | Posted: 11 Oct 2003 14:13 
judging by your other threads as well as this one, it sounds like your database is buggered or something.

do you have phpadmin or anything like that to take a look at the database with? if you don't then don't worry about it but if you do, take a look.

failing that, i know you've already reinstalled once, but it might be an idea to try it again. this time make sure that you put NEW table names in setup_options.php, eg:

$Tf='test2_forums';
$Tp='test2_posts';
$Tt='test2_topics';
$Tu='test2_users';
$Ts='test2_send_mails';
$Tb='test2_banned';

and upload to a new folder, eg:

http://my_URL.com/test

Author TinnyFusion
Registered
#9 | Posted: 12 Oct 2003 00:25 | Edited by: TinnyFusion 
ok 4days thank you for your suggestion, but I have tried with another database name already...and it was the same.
I have not tried with another directory/folder/table(s) name though but I can not see why this should be a problem really can you?

I'll give it a go just for the sake of it, here goes.

This is what I did:

1. Deleted old D:\Apache2\htdocs\code\forum folder.

2. Removed all 6 miniBB tables from MySQL.

3. Recreated the database using phpMyAdmin v2.5.3 (latest version) only this time called it forums.

4. Downloaded miniBB v1.6a again and unzipped to D:\Apache2\htdocs\forum just in case my original .ZIP was corrupt or something.

5. Went into setup_options.php and changed the following values:

$DB='mysql';
$DBhost='localhost';
$DBname='forums';
$DBusr='***********';
$DBpwd='***********';

$admin_usr='***********';
$admin_pwd='***********';
$admin_email='*****.*****@*****.com';

$main_url='http://*****.*****.net/forum';

$Tf='tinny_forums';
$Tp='tinny_posts';
$Tt=tinny_topics';
$Tu=tinny_users';
$Ts=tinny_send_mails';
$Tb=tinny_banned';


Nothing else has been changed at all.

6. Ran _install.php but got this message (for the first time):
Installation file is missing. Please, check your directory for_install_.sql

The file is not called _install_.sql so how can it find it?
I found _install_mysql.sql in the directory/folder...

So, I have 3 choices:
= Simply rename _install_.sql to _install_mysql.sql or just use phpMyAdmin to add the tables to my database, go into _install.php and tell it the correct file it needs...

First, I simply renamed the file to _install_.sql and tried to run through the install again.

Now it works fine (you may like to sort out that little issue).

7. I'm at the first stage of the install where it says:
Welcome to miniBB setup! etc...
[/b]

I clicked on Continue >>> and gor the following message:
All tables successfully created! Now you can:

Continue with miniBB options (see setup_options.php file)

Create forums

Go to admin panel...

...and use your miniBB right now! :)

Don't forget to DELETE _install.php file also as _install_.sql file from your directory!

DO IT RIGHT NOW!!!


8. I removed/deleted _install.php and my newly renamed _install_.sql (correct name here though).

9. I tried to log into my admin section but got a white screen? - tried to goto the main index.php for my forum but again just got a white screen...

Geez, I have never had these problems before...

I think miniBB is still got too many buggs if you ask me and should be called miniBB v1.6 (beta).

I double checked in phpMyAdmin and the forums database still had no tables in it?
I got the original _install_mysql.sql from the .ZIP file I downloaded before and edited it to change all 'miniBB' comments to read 'tinny'.

E.G.
CREATE TABLE tinny_forums
CREATE TABLE tinny_posts
CREATE TABLE tinny_topics
CREATE TABLE tinny_users
CREATE TABLE tinny_send_mails
CREATE TABLE tinny_banned

I then ran the SQL queries on the database forums. phpMyAdmin reported "Your SQL-query has been executed successfully" and gave me all 6 tables.

10. Tried to (again) log into my main admin page.

This would not let me log in....
It also seemed to me like the 'skin' was missing as I could see the table borders etc...

*** lets stop shall we ***

It looks like I have downloaded a worse version than I had before...at lease the [b}_install.php[/b] script knew what the .SQL text file was called for gods sake and I could log in after all!!!!

I think I will go back to phpBB2 and come back in a few months when miniBB is out of beta.

Do not get me wrong, I would much prefer to use miniBB but as you can see it is full of bugs at the moment.

Regards, TinnyFusion... A client/customer lost till your out of beta...

Author TinnyFusion
Registered
#10 | Posted: 12 Oct 2003 00:49 
My backup installation of miniBB still works fine except for the original issues.

No one can register as they get:
Error in user data: Unable to register new user. Possibly username or email already taken, or admininistrator info isn`t filled, yet

And when I am logged in (as Admin) I can not goto my prefs as I get:
There was a database error. Please report this problem (what you were trying to do etc.) to boards administrator, or contact the authors

I may just remove the 'password' section and have it so no one needs to register but only enter their username to post....(with the little bit of javascript to prevent this field being left blank).

If I was to do the above I would also need to simply remove the 'prefs' & 'register' items from the main header.

This is the only way that my BB will work ok as far as I can see....

I know that my installation of apache2, php, active perl, and MySQL are fine as I have no other issues with any other scripts etc...

All the above applications are the latest versions too.

At one point I even tried going to an old version of apache and php but it was the same...

Maybe you should have a look here: http://uk.php.net/manual/en/

Author 4days
Champi0n
#11 | Posted: 12 Oct 2003 08:58 | Edited by: 4days 
what's that supposed to mean?

happy to help, but it pisses me off when someone has a problem and then blames the script/code (which a shitload of other people are all using happily) rather than working out what mistakes they've made themselves (like maybe using tables with no data in them or something like that).

there's no need to insult minibb just because you can't get it to work properly. gl with what you're doing anyway

Author TinnyFusion
Registered
#12 | Posted: 12 Oct 2003 15:13 | Edited by: TinnyFusion 
As I said, I would much prefer to use miniBB as it is just what I want (if it would work correctly).

I am no php expert (but I know my stuff) and I have installed miniBB now over 12 times and as you can see its one problem after another.

I am not slagging off miniBB, I love the idea...but...(and it is a big but at the moment) its still full of bugs!

I will retest it in a few weeks/months to see if it works ok with the latest version of Apache, php, MySQL etc...

I say this because version 1.6a has been updated (to a worse version) while I have been trying to get this working without the revision number being changed, I know this as the first time the install went through without any issues, but when I downloaded the same version again it would not install - crazy I know.
I can only assume it had been 'altered' in some way as the _install.php script did not even have the right information for the MySQL tables?

One more thing about your support, I could not belive that in one post Team suggested to one poor soul that he go back to v1.x.x of Apache! - So you can use miniBB without all these issues/problems as long as you leave your computer wide open with an insecure version of Apache/php... NO thank you.

Keep up the good work and one day soon I hope, you will have a fantastic product.

Best Regards, TinnyFusion

Author Team
8-)
#13 | Posted: 13 Oct 2003 10:41 | Edited by: Team 
Let me be honest too - it seems, you are using some specific software, and without knowing OS version, server, mysql version PHP etc. we can not say exactly what is the problem. If you want, you can give me temporary access to your server so I can check this out and guess what's wrong.

Author MarcDK
Registered
#14 | Posted: 20 Oct 2003 21:07 
Ok, will someone perhaps be able to program a plug-in for a better Avatar-Handling with uploading, Useroptions ect? Is this hard to do?

Author Team
8-)
#15 | Posted: 21 Oct 2003 09:51 
MarcDK
First, it is hard to do, really. It is possible to program it, but after that it will be very hard to upgrade your board to the next versions.

Second, it is somewhere out of our concepts. We hate avatars.

Page  Page 1 of 2:  1  2  Next » 
How To miniBB Support Forums / How To / How did "Team" get his/her cool.gif? Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
 
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Proceed with the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB