miniBB ® 

miniBB

®
Support Forums
  
 | Start | Register | Search | Statistics | File Bank | Manual |
Specific miniBB Support Forums / Specific /  
 

Some problems with Noindex,Nofollow and Romanian language

 
Author Claudiu
Guest
#1 | Posted: 3 Jan 2022 21:24 
2 problems:

— in Romanian we have some diacritics and they are altered like &#emsb; something like that; the diacritics are included in the UTF-8 charset, however, I think is some sort of substr() but I do not know where and how to modify it;

— I have a no index, no follow problem in the Google console, I think it was at index?registernew or something like this

thank you!

Author Paul
Lead Developer 
#2 | Posted: 5 Jan 2022 18:00 
Claudiu:
in Romanian we have some diacritics and they are altered like &#emsb; something like that; the diacritics are included in the UTF-8 charset, however, I think is some sort of substr() but I do not know where and how to modify it;
miniBB pre-converts some defined entitites, and if an entity you described is not included in the list, you could add it on your own. The array is located under bb_func_txt.php -> convert_entities function. Most possibly you have to add what's supplied as ' ' and it should be converted to ' '.

It's actually not related to Romanian language and possibly comes in result of copying/pasting from software like MS Office or similar.

Also make sure you have converted Romanian language supplied in our Downloads section to UTF-8. It's an old version and it comes in ISO-8859-2. It will produce such results with many specific chars if not converted to UTF-8 (and you also must specify its meta content charset tag as utf-8).

Claudiu:
I have a no index, no follow problem in the Google console
I have no idea what kind of «console» do you mean. What's it about?

It's correct that Registration form should not be indexed. MiniBB produces index,follow tags only for the content pages which should be indexed. All other technical sections are not subject to index in Google and there is produced noindex,nofollow tag for them.

This however could be re-defined if you code your own version of the defineRobots() function (which could be re-defined putting under bb_specials.php for example).

Author Claudiu
Guest
#3 | Posted: 6 Jan 2022 20:39 
Google webmaster tools. I solved that! Thank you

But still cant figure it out with these:

Ș Ú Ú Capital S-comma
ș Û Û Lowercase s-comma
Ş Ş Ş Capital S-cedilla
ş ş ş Lowercase s-cedilla
Ț Ț Ț Capital T-comma
ț ț ț Lowercase t-comma
Ţ Ţ Ţ Capital T-cedilla
ţ ţ ţ Lowercase t-cedilla

It appears the code instead of the letter itself

Author Paul
Lead Developer 
#4 | Posted: 6 Jan 2022 22:39 
Claudiu
Could you open the source of your forums and check what charset encoding provided in the <meta> tag?
If it's not UTF-8, then as I've mentioned above, you should convert your language pack to utf8 and fix the encoding meta inside of it.

Surely you must make sure that your mySQL database has default utf8 as an encoding, too.

Author Claudiu
Guest
#5 | Posted: 6 Jan 2022 23:10 
In index page I have this line: if(!isset($chars_encoding)) $chars_encoding='UTF-8';
Where do I find the meta tag (sorry for all the questions...)?
Also, the db has UTF8 as default enconding

Still doesnt show the letters mentioned above...

Author Claudiu
Guest
#6 | Posted: 6 Jan 2022 23:26 
I think the solution is to include the characters in the convert_entities function. But I do not know what to write in the search array, considering the &#538 code and so on would be in the replace array

Author Paul
Lead Developer 
#7 | Posted: 7 Jan 2022 00:49 
Do you know how to view the HTML source of the page?

If not, what browser/OS do you use?

You have to achieve that your browser posts in UTF8, that's all. Now it posts in ISO.

(As you see above, you've posted all those chars on these forums, which are in UTF-8, that's the proof — but your forums are just not setup in UTF-8).

Author Claudiu
Guest
#8 | Posted: 7 Jan 2022 11:16 
Yes, got it now!!!
Meta shows iso in viewsource!!!

Where from can I switch that to utf8? Thanks A LOT!

Author Paul
Lead Developer 
#9 | Posted: 7 Jan 2022 18:11 
I suppose you probably use Romanian language you've got from our Downloads? It should be under /lang/rom.php.

If so, you should convert this file to UTF-8. Open it for editing; I recommend to use the Notepad2 editor for this (if you're on Windows), it creates very clean and acceptable UTF-8 encoded files.

So, open the language pack with this program, then go to File -> Encoding -> UTF-8. Important! Set just 'UTF-8' and not 'UTF-8 with signature'.

For the first sight, this file doesn't contain specific chars, but you may go through it and locate unnecessary sentences to fix. You could also translate some sentences missing, which are in English only — scroll down the pack, they appear below the comment saying

/* Values below relay on new miniBB version and were not included in original language pack by author previously. Feel free to translate and re-send to miniBB Team. */
Finally, go to the top of file and for the $l_meta var, set the value of:

$l_meta='<meta http-equiv="content-type" content="text/html;charset=utf-8" />';
Save the file (File -> Save) and re-upload back to your server.

You could re-send the modified and fixed file back to me, I could update it in Downloads, mentioning your name or website.

For this, upload it here using the File Bank (click the button above the posting form).

Or you could just email it to me via ghappa [at] gmail {dot} com .

Author Claudiu
Guest
#10 | Posted: 8 Jan 2022 16:47 
Still doesn't work... I can't get it, with the utf-8 setting, not even these chars don't work anymore — ă, â and î

Author Paul
Lead Developer 
#11 | Posted: 8 Jan 2022 18:19 
If you check the source of our forums, meta charset is utf-8 and all chars you've mentioned, are posted well. It works if configured properly. Could you try your forums with the default English language pack?

So, the problem could be either with your meta charset encoding (double check you've uploaded the modified file on server), either with the database. In miniBB Manual, we also have a paragraph describing in detail of how could you check and set your database encoding properly.

Author Claudiu
Guest
#12 | Posted: 8 Jan 2022 21:07 
I added this
$mysql_set_charset='utf8';

as the last line in setup_options.php and now it works alright!

Thank you!!!!!!

Author Paul
Lead Developer 
#13 | Posted: 9 Jan 2022 18:39 
Perfect, thanks for letting us know!

Specific miniBB Support Forums / Specific /
 Some problems with Noindex,Nofollow and Romanian language
 Share Topic's Link

Your Reply Click this icon to move up to the quoted message


 ?
Post as a Guest, leaving the Password field blank. You could also enter a Guest name, if it's not taken by a member yet. Sign-in and post at once, or just sign-in, bypassing the message's text.


Before posting, make sure your message is compliant with forum rules; otherwise it could be locked or removed with no explanation.

 

 
miniBB Support Forums Powered by Forum Software miniBB ® Home  Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contact Us
Install the Captcha add-on: protect your miniBB-forums from the automated spam and flood.


  ⇑