miniBB Support Forums | 18 years on The Web
miniBB ® 

miniBB

®
  
 | Start | Register | Search | Statistics | File Bank | Manual |
Specific miniBB Support Forums / Specific /   
 

Forums home page layout messed up after installing Mobile add-on v2.1.3

 
Author marsbar
Associated Member
#1 | Posted: 26 Jul 2020 12:48 
Hi, Paul.

As mentioned in the "Bad cookies" thread, I uninstalled Mobile add-on v1.5 and then installed the current version 2.1.3 earlier today.

I do not know whether installing Mobile add-on v2.1.3 is supposed to change the display of my forums' home page -- please see description of "before" and "after" below.

Please note: I use miniBB's old-school layout templates ($startPageModern = False;). My forum is installed in a sub-directory: www.example.com/forums/.

Previously, my forum home page would display, from top to bottom of page:
(1) Forums section which consists of a heading, followed by a table showing the forums and their respective descriptions and statistics; and this section is followed by
(2) Recent discussions section which consists of a heading, and a table showing latest discussions (topic, views, originally posted by and when, latest posted by and when).

However, now I get:
(1) Recent discussions section that is sort of broken: table is missing its header (th).
(2) Forums list — missing section heading, and the table. I get the new style layout (rather than the original "old-school layout").

Somehow the modern style miniBB templates/styles have partially taken over my forums' home page?! :(

Your help and advice will be gratefully received.

With thanks,
marsbar

Author Paul
Lead Developer
#2 | Posted: 28 Jul 2020 17:14 
Are you sure you didn't override the default templates with mobile templates set? Default are located under /templates/, mobile are located under /templates-m/ .

The Mobile script uses some default templates, so your miniBB version, and templates, in general, should be compatible with the Mobile layout. Did you check the compatibility with your current version before you install something? Mobile add-on's readme says miniBB version: 3.4 and up.

For lower versions, this add-on simply won't work. Specifically, you should have CSS file and generic templates being compatible with the newer release. I see that you still use /bb_default_style.css — but the CSS files structure and naming is different for the newer miniBB.

If some of the current templates differ from default structure, you could add them in /templates-m, then the script, if it finds the template in the mobile folder, it will load it first and skip the default.

My recommendation is to revert everything you have now, to the previous version :-)

Then you could try to install a default miniBB somewhere on server, but using your current database. And install the Mobile template over it to make sure it really works on your side.

Author Paul
Lead Developer
#3 | Posted: 28 Jul 2020 17:20 
P.S. Firefox has a great tool to debug the website as it would be loaded from the Mobile device. Open your forums URL in Firefox, press Ctrl+Shift+M. In the field where it says "Custom user agent", type in: phone and then just reload the URL, clicking it above in the location field. The page should refresh, containing the Mobile templates set loaded. Viewing its source, you could get to many ideas what's wrong.

Author marsbar
Associated Member
#4 | Posted: 8 Aug 2020 16:12 
Good news, Paul: I have sorted the problem! The fix was way easier than identifying what had gone wrong.

What had gone wrong? Old marsbar had suffered a couple of Specsavers' Moments:

a) The broken forums home page issue --> $startPageModern incorrectly set.

b) The plain, unstyled mobile version forums --> "new" default CSS was missing, which is little wonder, given that my forums had until now used only my heavily customised bb_default_style.css.

Embarrassing rookie mistakes they are, but I have learnt lots during the troubleshooting process.

While I am happy to see my forums "looking" presentable again, I am even happier to know that my existing templates (from v1.x) are still supported by the latest version miniBB.

Happy weekend--
marsbar

Author Paul
Lead Developer
#5 | Posted: 8 Aug 2020 18:15 
They are truly good news, and I'm glad you solved, and provided some tips which may be useful to others. Thanks!

Specific miniBB Support Forums / Specific /
 Forums home page layout messed up after installing Mobile add-on v2.1.3
 Share Topic's Link

Your Reply Click this icon to move up to the quoted message


 ?
Post as a Guest, leaving the Password field blank. You could also enter a Guest name, if it's not taken by a member yet. Sign-in and post at once, or just sign-in, bypassing the message's text.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.

 

 
miniBB Support Forums Powered by Forum Software miniBB ® Home  Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contact Us
Get the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
 ⇑