miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
Re-cycled miniBB Support Forums / Re-cycled /   

Bad words add-on giving Empty delimiter error

Author Guest
#1 | Posted: 19 Nov 2008 10:47 
Weird bug here, I just installed Bad_Words plugin and I went to start a new topic with the word "string" as the topic title and got these errors. The same thing happened when I tried to send a private message with "string" in the body? I tried on the forum here and works fine. What might be causing this on my site? Is bad_words removing the word string, making the topic title to short and give an error?

Topic title can not be empty, and it must be descriptive for other users. Try using longer description.


Warning: explode() [function.explode]: Empty delimiter in /home/me/forum/addon_badwords2.php on line 10

Warning: Invalid argument supplied for foreach() in /home/me/forum/addon_badwords2.php on line 11

Warning: implode() [function.implode]: Invalid arguments passed in /home/me/forum/addon_badwords2.php

Also how do you get addon_badwords2.php to not show error messages? I added if (!defined('INCLUDED776')) die ('Whoops.');
but doesn't seam to work. Thanks

Author Guest
#2 | Posted: 20 Nov 2008 11:22 
Well I have been tinkering around with this for an hour. I've came to the conclusion that it works fine with your addon_badwords.txt but if I try and edit it at all it gives explode/implode errors all over when trying to post. When I edit the addon_badwords.txt I checked it with a py script using repr() and know it has the end of line char \n\r. If I try to post any code it fills the page with those errors, could it be picking up the \n in the code or paragraph and thinking its an Empty delimiter?

Author Paul
Lead Developer
#3 | Posted: 21 Nov 2008 03:55 
From the add-on's README I think this is what causing your issue:

==IMPORTANT==
All prohibited words are stored in addon_badwords.txt
These words must be separated by eofs (end of lines):
to do that simply press enter after typing each word.
THERE MUST BE NO ENDING LINE AFTER LAST WORD!


Re-cycled miniBB Support Forums / Re-cycled / Bad words add-on giving Empty delimiter error Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Get the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB