miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
The Other miniBB Support Forums / The Other /   

Old versions download

Author olafmarzocchi
#1 | Posted: 23 May 2007 04:08 
I need an old version to diff it against a patched miniBB forum.
Is there a page with old releases? I need a 2.0 RC x version, probably RC2.

Author Paul
Lead Developer
#2 | Posted: 23 May 2007 06:30 | Edited by: Paul 
Sorry, we do not offer older versions for download. The only version you can download on our site, is the latest release. You can upgrade any older miniBB version to the newest release with no troubles, I suppose.

However if you did a lot of modifications in your older version, it would be worth to mention them in some documentation file for your own purposes at the time when you did them or at least to keep the version you used as an archive. Unfortunatelly, if you did not, nobody could help you in restoring that.

Author olafmarzocchi
#3 | Posted: 24 May 2007 01:40 
I always keep copies of the sources, but it wasn't me that made the modifications.

Anyway, I'm quite disappointed, since I don't see any real problem in releasing, upon request if not always, the sources, the developer(s) surely have them.

Not even diffs?

I then, I ask other people reading this forum: could you please send me at olaf . marzocchi then gmail the 2.0 RC2 version if you still have it?

Author olafmarzocchi
#4 | Posted: 28 May 2007 07:21 
Thanks to a miniBB forum user, I now have 2.0RC2.

Thank you.

Author Paul
Lead Developer
#5 | Posted: 28 May 2007 10:04 
Glad the community may help you :-) Cheers.

Author Rider
#6 | Posted: 24 Aug 2014 00:17 
I am facing a huge upgrade of the forum, of which I've been the admin since a few weeks. We are running 11 versions behind, we're at 2.2a now. It will become a nightjob to go through all changes mentioned in !UPDATE.txt.

Splitting up the upgrade into, say, three pieces, will make the process more humane I hope. But then I will need some old versions of the software.

Could anyone send me the 2.4a and 3.0 releases, please? I am at gitaarbouwer at hotmail.


Author Paul
Lead Developer
#7 | Posted: 24 Aug 2014 17:27 | Edited by: Paul 
You don't need to follow all updating instructions line by line. Overwriting all .php core scripts would be possibly a first step, because most of them are renewed since this outdated version you have. Other than that, follow templates changes and update your templates manually, if they were customized; if they are default, you could just overwrite them as well. Also, you need to execute some commands to upgrade the database.

I'm not sure if you need to spend few days for this, if you have a default version of the scripts, we could do the upgrading process in a few hours for the rates suggested under the Premium Support.

You also need to upgrade to the latest version. Upgrading to earlier versions means you are not upgrading at all...

Author Rider
#8 | Posted: 24 Aug 2014 23:29 
lol... you make me doubt. Maybe with a bag of chips and a bottle of coke I can get it done it in a few hours. Sounds interesting. I'll think about it.

The Other miniBB Support Forums / The Other / Old versions download Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.

Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Try the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB