miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
Specific miniBB Support Forums / Specific /   

Posting code iframe error

Author Bluesplayer
Registered
#1 | Posted: 4 Feb 2014 14:22 
On entering code into a post parts of it are running - the iframe part, yet it doesn't run on this forum. Either I have removed something or I should add something?

Author Paul
Lead Developer
#2 | Posted: 4 Feb 2014 14:41 
Sorry, didnt get it - what kind of code do you mean?

On this forum, only those codes on the BB buttons visible above are available.

Author Bluesplayer
Registered
#3 | Posted: 4 Feb 2014 15:18 
Well I attempted to describe the YouTube Video Search on my own forum, posting all the different file alterations as I did on this forum. When I added the bb_code new youtube iframe code to the post my own forum displayed the iframe itself, which didn't happen on this forum.

Author Paul
Lead Developer
#4 | Posted: 4 Feb 2014 18:21 
Not sure why our forum should display your solution? At first, we do not even have the exact solution present by this moment. Second, even if we would have, I will not install it here. We do not need videos embedded for the miniBB support board.

Author Bluesplayer
Registered
#5 | Posted: 4 Feb 2014 18:56 
Paul:
Not sure why our forum should display your solution? At first, we do not even have the exact solution present by this moment. Second, even if we would have, I will not install it here. We do not need videos embedded for the miniBB support board.

We are cross purposes here I think. This isn't an enhancement I'm talking about but a fault with my own board. I was just wondering where to look for the fault. Anyway I can live with it at present.

Thanks

Author Paul
Lead Developer
#6 | Posted: 5 Feb 2014 13:20 | Edited by: Paul 
Sorry for misunderstanding, sometimes questions are so simple that I could make them too difficult :)

So, it sounds logical to me. You have applied some of the code which supports iframe tag, to your board. We do not have anything iframes-related on this board. That is why, on your board the code converts to the iframe, on our not.

In this case, I can not be responsible for your code. It seems like we are coming again to the task which I need to handle on my own for free and analyze what is wrong, but I do not have time for this now, sorry. This is your idea, your solution and actually it is about the 3rd party code which I can not support. This solution may be still interesting for other users, but you need to have a stable, clearly instructed and secure solution, else who would be intrested in it...

Author Bluesplayer
Registered
#7 | Posted: 5 Feb 2014 20:37 
I realise what this problem is now. The alterations to bb_code.php - the iframe match - was exactly as I posted in my explanation of my YouTube Video Search code, and that is why the iframe was being displayed. This won't be a problem in the future as only an exact bb_code.php match will cause concern.

Must admit I have learned a huge amount about bbcode whilst figuring out my video search code. I think I can quite happily create new minibb features now without going mental and also with acceptable code too.

Author Paul
Lead Developer
#8 | Posted: 7 Feb 2014 16:51 
Great, you are welcome :)

Specific miniBB Support Forums / Specific / Posting code iframe error Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Check out the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB