miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
Specific miniBB Support Forums / Specific /   

miniBB ($main_url) IP config

Author Blue Thunder
#1 | Posted: 15 Nov 2006 02:27 
Im not sure if this has already been cover, because I cant find anything on this problem.

Ive installed miniBB onto my server which is the computer im currently using (connected the

net via firewall, router/NAT), so its http ip is

My server's internal ip is 192.168.x.x
and its external ip is

Ive tried to put all three of these as the $main_url setting (,

but only 192.168.x.x allows me to login as an admin. ( just stays at the same admin

login page unchanging except when the login is wrong, and i obiviously cant connect using

the external ip).

Now everything would be fine with using the 192.168.x.x ip, except when other people try and

connect to the forum (via internet) it keeps trying to connect to 192.168.x.x, which is my

internal ip and therefore wont work (they need to use the external ip which i cant connect


Is there anyway to work this out? Or will i have to install miniBB via a remote computer?

Author Paul
Lead Developer
#2 | Posted: 15 Nov 2006 03:24 
You should have install miniBB on the computer which is available to public, that's all I could say. If you can not login as admin, most probably the problem is related to cookie settings/options.

Read for more: Admin login troubles thread.

I'm myself developing miniBB on local PC with local address ( and everything works just fine. It's just a matter of proper configuration of the server.

Author Blue Thunder
#3 | Posted: 15 Nov 2006 06:10 
About the cookie settings/options: When I used the 192.168.x.x address it allowed me to login as normal, but wouldnt when using other ips. Is it possible to attribute this problem to cookie settings/option since it acutally does work?

The server is open to the public, its just that because Ive specified my own internal ip in the $main_url (I dont have a domain name so I have to use an IP), anyone connecting from the outside (via and clicking anything on the forum page will be directed to the appropriate page under the ip of 192.168.x.x instead of the ip they originally entered through (, rendering them unable to continue.

The only solution I can see is to reinstall miniBB from a remote computer that is not within my local network.

Author Prince
#4 | Posted: 27 Aug 2010 08:01 
I have unique ip for my forum..

so I'm making mirror (subdomain) with that unique ip to open my sites in some country that have been filtered..
but when I make it it just open first page of forum.. when user clicks on the forms or last discussions it redirects to original forum address..

Before I saw the minibb forums we could go with main address or it's unique ip.
when we entered subdomain as unique ip it automaticly opened all link with that address..
I Mean any address we put it opened that address and all links of forum worked with that..

but now it's not like this.. just if we put the new mirror address it just for first page and other links are same as before..

hope you understand what I mean..

Author Paul
Lead Developer
#5 | Posted: 28 Aug 2010 13:00 | Edited by: Paul 
Sorry. I don't understand :)

You may build $main_url setting dynamically in setup_options.php. Knowing the IP of the server you may put something like

if($ip=='') $main_url='mirror';
else $main_url='original';

You may get the IP analyzing one of the $_SERVER variables of PHP.

That's all I have to recommend so far...

Author Prince
#6 | Posted: 30 Aug 2010 08:04 | Edited by: Prince 
Thanks.. ;)

that works.. but...


if($ip=='') $main_url='mirror';
else $main_url='';

if I made it like this that works.. but the smile code will not..

it shows like this:


If I do it like this:


if($ip=='') $main_url='mirror';
else $main_url='';

it will be same like before and just opens first page with mirror..

Author Paul
Lead Developer
#7 | Posted: 30 Aug 2010 11:17 
$main_url is a mandatory setting and it can't be empty.

You should have smileys available on both servers you run forums on (the same as other graphics or external files you may have).

Author Prince
#8 | Posted: 1 Sep 2010 04:12 
it won't work correctly in my side.. I don't know..

and also if I put]

it just for first page..

for other pages it will be the same..

Author Paul
Lead Developer
#9 | Posted: 1 Sep 2010 06:02 | Edited by: Paul 
Sorry... I have no ideas, too, it's a very specific question.

Specific miniBB Support Forums / Specific / miniBB ($main_url) IP config Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

You are welcome to post anonymously, by entering a nickname with no password (if the similar Username has not been taken yet), or by leaving both fields empty. If you have a forums account, you can also sign in from this page without posting a message, or sign in and post at once.

Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Try the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB