miniBB Support Forums | 16 years on The Web
miniBB ® 


 | Begin | Register | Search | Statistics | File Bank | Manual |
Specific miniBB Support Forums / Specific /   

Human authorization is empty?

Author ramchandra
#1 | Posted: 4 Feb 2013 17:04 
Hello, I just bought a human authorization plug-in and I can not make it work.
There is no picture, the test .png is empty, and after all the settings it is on
the correct place and seemes working (for new registration) but empty again.

I thought that my server does not have PHP - GD library, but.. it turns out it does, and
I think free type lybrary is auto instaled - ubuntu 12.04 server with Apache2 and PHP5.

What maybe the problem? Some restriction on server? Please help.

Author Paul
Lead Developer
#2 | Posted: 4 Feb 2013 18:21 
The first thing you may check: right mouse-click the picture, choose Properties, and check its direct URL.

Copy this URL to memory buffer and paste it directly in the browser's Address bar. In other words, directly go to this picture.

Most hopefully you could see the nature of the error displayed (if errors in your PHP are turned to be displayed).

If not, let us know...

Author ramchandra
#3 | Posted: 4 Feb 2013 18:49 | Edited by: ramchandra 
Thank you Paul.
I did what you suggest and the result is just like the test png - empty background.

Here is a screenshot:

Here the screenshot, sorry
I checked the logwatch file, no this kind of errors. Maybe something with the free type?

Author Paul
Lead Developer
#4 | Posted: 4 Feb 2013 20:16 | Edited by: Paul 
It seems you just have PHP errors turned off...

Anyway, there is one more way to debug: modify addon_captcha.php and closely to the very end of this file, comment these strings of code that way:

//imagepng ($im);
//imagedestroy ($im);

and point to this image directly again after resaving the file; it will not output the image pointer, but most hopefully will report an error... Also, at the very top after opening <?php you may put:


One other thing you could try as well: specify DIRECT disk paths to fonts under addon_captcha_options.php -> $fontsPath.

By default, it's relative:


but you could try to make it absolute, f.e.:


(it very depends on the path to your files on server, which you may know via getcwd() function of PHP - example below will not work, if you just copy/paste it).

Author ramchandra
#5 | Posted: 4 Feb 2013 20:25 | Edited by: ramchandra 
The fonts path is set to absolute, I will just try the rest of your post :)

the path to fonts is


but I have another fonts folder at


Could this be a problem?

Author ramchandra
#6 | Posted: 4 Feb 2013 20:47 | Edited by: ramchandra 
Yes, stupid me, everything is OK now.
The permisions for the fonts folder were not right. Last week I had the same with a picture folder, took me half a day
to find out the reason :)

All the best and thank you.

Author Paul
Lead Developer
#7 | Posted: 4 Feb 2013 21:59 | Edited by: Paul 
Glad it works for you :) Enjoy.
(I'll put a note in readme about file permissions, interesting issue...)

Author Jaime
#8 | Posted: 5 Feb 2013 14:05 | Edited by: Jaime 
took me half a day to find out the reason :)

Sometimes I "love" those self-fabricated problems, even if it cost me a few gray hairs =8). But the sense of achievement when you have then found their own mistakes is wonderful. ;-)

Author ramchandra
#9 | Posted: 5 Feb 2013 14:26 
True :)

Specific miniBB Support Forums / Specific /
 Human authorization is empty?
 Share Topic's Link

This topic is closed. New replies are not allowed.


miniBB Support Forums Powered by Forum Software miniBB ® Home  Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contact Us
Proceed with the Captcha add-on: protect your miniBB-forums from the automated spam and flood.