miniBB ®  
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
Specific miniBB Support Forums / Specific /   

cannot post: error message ' message too short or empty'

Page  Page 1 of 2:  1  2  Next »  
Author youki
Guest
#1 | Posted: 5 May 2012 12:47 
Hi,

I just compiled the latest version with paid add-ons.
Install went smooth, reinstalled the database without problem.
But I have this annoying problem: I cannot post without seeing an error message' message too short, start again'.
Not saying this is a bug as I have found no other post about this problem.
Might be a local problem; where should I start to look to solve this problem ?
( I had the same problem with a previous version: MiniBB 2.5, this is why i decided to upgrade to the latest version but problem is still there.)

thank you for your help
regards

Author tom322
Registered
#2 | Posted: 5 May 2012 18:14 
You didn't describe what you do and when exactly it happens (always or only when you post short message). You can look at main_posts.html template and experiment with:

var tlength={$post_text_minlength};

(maybe change it to var tlength=0; and see what happens). You have javascript mixed in this template, most likely.

Author youki
Guest
#3 | Posted: 5 May 2012 18:39 
Hi Tom ,

thanks for your answer.
I often prepare my text in TextPad, the copy/paste to the forum, never had any problem.
Suddenly since yesterday the text is being refused as 'being too short' ( several lines)

I tried to copy text directly from internet : " lorem ipsum..." : it is accepted.
So the problem happens at random: sometimes accepted, sometimes not.

I tried to play with the $post_text_minlenght : no changes or improvement
even deleting line 86 in main_post.html template doesn't work: message still appearing.

I have done another install on a test domain without importing my old database: no change.
Weird. Happened suddenly. Will try to think about what I could have done wrong.

regards

Author youki
Guest
#4 | Posted: 6 May 2012 17:37 
I have tried the following :

- posting from Firefox: cannot post
- posting from IE: idem
- post from another computer : idem
- done about 10 full reinstall:
* compiled v.3 with addons: negative
* version 2.5 : negative
* version 2.5 + old database: negative
* several clean install without data: negative
- variable txt_min_lenght in setup_options doesn't change anything, tried to set to zero, 1 , uncomment...

problem is that this happen randomly
at this point, I am not interested to finding the cause of this behaviour; I want to know if it is possible to delete a few line of codes to get rid of the error message "message too short or empty, try again" ( approximative translation from the french message I read.)

Most message are moderated, so I don't care about this protection : is it possible to delete the code or the function causing this problem ?

rgds

Author youki
Registered
#5 | Posted: 7 May 2012 01:16 | Edited by: youki 
Making some progress: I noticed this behaviour is caused by french accents: é,à,è, etc...
No error message " message too short or empty" when submitting message without accents.


website meta:
meta http-equiv="content-type" content="text/html;charset=iso-8859-1
MiniBB setup option: language " fre"

Mysq DB l: MySQL charset: UTF-8 Unicode (utf8)

any idea how to correct this ?

Author Paul
Lead Developer
#6 | Posted: 7 May 2012 09:12 
Do you mean that the message is the same as it's defined under the variable $l_emptyPost in the language pack?

I didn't understand where this error message is displayed? Is it JavaScript alert or the standard screen? Because there is no such exact message in miniBB.

It can't happen randomly, there must be a strict condition of it, and I doubt it's because of the French language. There are thousands of miniBB users from France, which never met with such a problem.

If you are legal buyer of the premium add-ons, you can just drop me the private email (you've got my email from the order letter) and provide the URL to your forums. I can take a look then and try to conclude what's wrong.

Author youki
Registered
#7 | Posted: 7 May 2012 11:36 
Thank you Paul for your answer.
I have sent you an email.

Author Paul
Lead Developer
#8 | Posted: 8 May 2012 11:50 | Edited by: Paul 
Ok, I've got it.

I also agree it is important to always use latest version but I could not adapt the template to the 'integrity' one which is the one I absolutely prefer . So, I have ' downgraded' to the 2.5 miniBB version and installed without problem the "old" template.

Well, you can still have miniBB 3 and your older templates. This is not a problem, it's possible. But you need to have newer files to test. Specially I think you may try to update to the newer version of bb_func_txt.php. It should be compatible with the older version.

Whatever is needed to be upgraded, are core .php files and all add-ons. You can get such version from the the Compiler. Then use your templates, but verify them comparing to the newer ones. You need to paste all differences manually. Going template-by-template, you will have a newest version, but with your customized templates. You can do it on your own, also referring to the "Updates History", or hire me for about $50 for that. Further to that, all future upgrades will be much easier.

I've tried to post a message with a lot of French symbols, but it seems it didn't pass at all. However if I simply type "test", such message goes on. There should be some point to upgrade at least some partial stuff like I mentioned above because of that.

But there also may be some problem with your older template. It seems the message we get is contained in $l_emptyPost variable of the language pack. That means some function cuts off the message to have zero length, but I can't say the reason without seeing the codes. Whatever I have to say because of that, - you must have the latest release with all updated functions installed :)

Author youki
Registered
#9 | Posted: 8 May 2012 13:54 | Edited by: youki 
Thank you Paul for your detailed answer.
I have deleted all files on the server and done a fresh install with a brand new compiled V3.0 ( add-ons included).
I have just completed the setup_options.php file with database info and uploaded the shared_files/uploaded images plus the fre.php language file.
I touched nothing else.
One nice thing about miniBB is that everything can be reinstalled in no more than 10 minutes.

I did a test and the problem is still there.
regards
Henri

Author Paul
Lead Developer
#10 | Posted: 9 May 2012 15:15 
Well, for me now it seems I can post the message in French full of French accents letters.
So if you still have the problem, could you describe it more widely?

Author youki
Registered
#11 | Posted: 9 May 2012 20:20 | Edited by: youki 
test

test2

I see two problems:

- french accents are unreadable
- if you try to post a new topic as 'admin' with accents, you have the usual error message.

Do you think this could be tied to the server ? I could try another one.
I have already tried afresh install on another domain name hosted on the same server but problem is still there.

I have developed static pages in various directories, ( i.e domain.com/pages/ page1.php, page2.php etc...) could this be a problem for miniBB ?

Author youki
Registered
#12 | Posted: 10 May 2012 00:17 
test3

I have installed a WAMP server on my desktop and installed MiniBB: well, it works correctly.

The shared server could be faulty. don't know why but I'll have to find a new hosting company.
Thank you for your time and assistance.

Author youki
Registered
#13 | Posted: 10 May 2012 01:20 
test4

test5

I have done a last test on the servers on my hosting company : they authorise to choose between different versions of PHP 5.2 , 5.3 or 5.4

I have had no problem with PHP 5.2 : miniBB works OK on this server, problems seems to come from the PHP 5.4 installed on that server.

regards

Author Paul
Lead Developer
#14 | Posted: 10 May 2012 14:20 
Well, I'm mostly sure the problem is not on PHP side :)
I have posted the text, and it went properly. If the text doesn't went on your side, there is some miscorrelation with encodings... it could be your browser, or something on the client side which I don't have idea about.
Anyway, does it work on your end now?

Author youki
Registered
#15 | Posted: 10 May 2012 17:59 
Yes , no problemo :-) problem solved.
Since I reinstalled everything with PHP5.2 on the shared server, it's ok.

Thank you for your assistance.

Page  Page 1 of 2:  1  2  Next » 
Specific miniBB Support Forums / Specific / cannot post: error message ' message too short or empty' Top
Your Reply Click this icon to move up to the quoted message
 Short link for this topic:

 ?
You are welcome to post anonymously, by entering a nickname with no password (if the similar Username has not been taken yet), or by leaving both fields empty. If you have a forums account, you can also sign in from this page without posting a message, or sign in and post at once.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
  Extend your miniBB-forums, attaching the images and files,
get the File and Picture Attachments add-on!
Galleries / Attachments Addon for miniBB