miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
The Other miniBB Support Forums / The Other /   

Setting default language charset for Apache server

Author Koba
Registered
#1 | Posted: 8 Feb 2005 14:22 
I got the language pack from this site but whenever I load the page I get the 'garbled text' and I have to view the encoding manually. The fonts in the style sheet are OK for Russian 1251 encoding and I've tried various things with the meta tags to no avail. Any ideas?

Author Team
8-)
#2 | Posted: 8 Feb 2005 14:36 
First of all, open page's source (VIEW->SOURCE) and check, either encoding is REALLY Windows-1251 inside the generated page.

Second, this problem could appear with some Apache installations. If Apache server is "russian", and not original like on their downloads page, I know some cases when this happened. This could be fixed only in Apache settings then.

In our forums, you can set Russian language pack, too (in your profile), and see, will it work or not. If it will - you have server problem.

Author Koba
Registered
#3 | Posted: 8 Feb 2005 21:45 
Ok So its a server problem then. Thanks for informing me. My testing server is Apache2triad at the latest addition running apache 2.0.

So when I upload the forum and I still have issues.... in exactly what way should I scream at my hosting company? Like if I were to tell them 'Russian Language isnt being encoded on command correctly' would that do the trick or is it something like ...

You need to set X variable in your foo.ini file to Y

Author Team
8-)
#4 | Posted: 9 Feb 2005 10:56 
what way should I scream at my hosting company?

First of all, be sure it's a server problem. Create another HTML, or PHP page which uses Windows-1251 encoding, and run on server. After that, you of course can claim your provider. It's a very usual problem, and there is one setting in Apache which allows to set default encoding (I don't remember exactly which one, but administrator should know it better).

Author Koba
Registered
#5 | Posted: 9 Feb 2005 13:46 
I have the following:

//

AddLanguage ru .ru

//

LanguagePriority en ru ca cs da de el eo es et fr he hr it ja ko ltz nl nn no pl pt pt-BR

//I changed the following to WINDOWS-1251 but it didnt work

AddDefaultCharset ISO-8859-1

//

AddCharset WINDOWS-1251 .cp-1251 .win-1251

//

Author Team
8-)
#6 | Posted: 9 Feb 2005 13:49 
I can not recommend you something, I am not Apache guru... maybe someone here knows it better.

Author Team
8-)
#7 | Posted: 9 Feb 2005 13:50 
Yes, maybe changing this:
AddDefaultCharset ISO-8859-1
to that:
AddDefaultCharset WINDOWS-1251

could help; but don't forget to RESTART Apache after this change is made.

The Other miniBB Support Forums / The Other / Setting default language charset for Apache server Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Get the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB