miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
FAQ miniBB Support Forums / FAQ /   

Installation problems, difficulties, hints; Database / configuration error via installation

Page  Page 5 of 7:  « Previous  1  2  3  4  5  6  7  Next »  
Author Anonymous
Guest
#61 | Posted: 10 Dec 2002 05:43 
It is working. Ensim has automatically used lower case for my database and I used capital letters

Author 4days
Champi0n
#62 | Posted: 10 Dec 2002 14:24 
damn case-sensitivity :)

Author Anonymous
Guest
#63 | Posted: 11 Dec 2002 09:38 
6 Oct 2006 04:40 - Attached on mergeing:
installing error

When I key in url:
and press enter then it apear
Database/configuration error.
in the browser
please help thanks!

Author Team
8-)
#64 | Posted: 11 Dec 2002 10:25 
You can incorrectly configured your database settings (login, password, DB name in setup_options). Please note that every value of mentioned is case-sensitive.

Author Anonymous
Guest
#65 | Posted: 11 Dec 2002 12:23 
Could you write a example for installing.
I should modify fields.
thanks

Author Team
8-)
#66 | Posted: 11 Dec 2002 13:00 
If you don't know database name, then know about it from provider... Server is usually 'localhost', but can be also an IP. Name and password are also given by provider.

Author arthas
Registered
#67 | Posted: 24 Dec 2002 04:34 
6 Oct 2006 04:50 - Attached on mergeing:
the _install.php becomes a source code

When I put miniBB to Linux and I install it ,why the _install.php become to source code?
I have install apache ,php,mysql.
Can you explain how to install to linux?
Thanks!

Author Team
8-)
#68 | Posted: 24 Dec 2002 10:51 
In Apache, you need to configure extension .php as PHP module. If it doesn't work, in your PHP ini file correct PHP quotes (it should work with <?php and <? )

Author arthas
Registered
#69 | Posted: 25 Dec 2002 04:33 
Actually,I do not know.
I open the php.ini and extension.php.
Both of file is default,I dare not modify the file.
Please teach me.
You should not give me up!
right!
Thanks

Author Team
8-)
#70 | Posted: 27 Dec 2002 10:20 
No, in Apache, you should edit httpd.conf file, and there should be the line

AddType application/x-httpd-php .php .phtml .php4

within the AddType section.

Author Guest
#71 | Posted: 21 Feb 2008 03:48 
Hi guys,
I got stuck installing miniBB:

1.) While running _install.php it mourned:
"We recommend to set permissions for generic forums folder as read-only."
Though that's how they are set!? I ignored that...
What filepermissions am I supposed to set?

2.) I added some forum - which then is in the dropdownmenu under "edit forum".
But I can't see it under index.php. Why could that be?

3.) There is no "login" button for regular user - just "sign up". That can't be right either.

If anyone could give me a hint, what I'm doing wrong, I'd be glad.
Thanks in advance!
sven

Author Paul
Lead Developer
#72 | Posted: 21 Feb 2008 06:10 | Edited by: Paul 
Guest:
What filepermissions am I supposed to set?

You don't need to set some speciall permissions (though read-only for core forums are recommended), and installation process just warns you your folder is vulnerable for some reason.

Guest:
I added some forum - which then is in the dropdownmenu under "edit forum".
But I can't see it under index.php. Why could that be?

Try to set

$startPageModern=FALSE;

in setup_options.php. Until you have not posted any kind of topics, new layout will hide the forums listing (because new layout is oriented on the forums which already have some topics, at least 10 or 20 so they could appear on the left side).

Guest:
There is no "login" button for regular user - just "sign up". That can't be right either.

Login boxes should appear straight on the first page or under posting forms. Like you see on our forums here!

Author Guest
#73 | Posted: 21 Feb 2008 13:29 
Paul:
Try to set
$startPageModern=FALSE;


Done - Works! Great!!
I see my test fora now and got a loginbutton.

Did I miss it or should that be mentioned somewhere in the readme?
How could it work on a first install that way?


Paul:
You don't need to set some speciall permissions


So 755 is correct ... Fine...

Author Paul
Lead Developer
#74 | Posted: 21 Feb 2008 13:32 | Edited by: Paul 
Guest:
Did I miss it or should that be mentioned somewhere in the readme?
How could it work on a first install that way?

I suppose we missed it because in the default installation it should be set to FALSE (was set to TRUE so we've updated the default package today to avoid that).

Permissions: some servers may allow to write in the folder by a PHP script by default even if permissions appear to be read-only. It could be useful for some script which have an "auto-upgrade" feature, for example. If miniBB installation reported that first it means it was able to create a temporary file there; that's why it means other scripts may create files as well, and it's not the best configuration (vulnerable). Try to ask your provider for more.

Author Mekdim
Registered
#75 | Posted: 22 Feb 2008 02:25 
I can access the bb_admin.php, add forum, other links but after adding forums I get a blank page on the index.php. The forums, sign in and post reply are not displayed.

What is the error?

Thx

Page  Page 5 of 7:  « Previous  1  2  3  4  5  6  7  Next » 
FAQ miniBB Support Forums / FAQ / Installation problems, difficulties, hints; Database / configuration error via installation Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

 ?
Only registered users are allowed to post here. Please, enter your username/password details upon posting a message, or register first.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
 
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Try the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB