miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Reply | Search | Statistics | Manual |
FAQ miniBB Support Forums / FAQ /   

Admin Login problems

Author Anonymous
Guest
#1 | Posted: 9 Feb 2004 20:03 
Hi,

after installing and testing xitami server 2.5c1, php 4.3.4, mysql 4.0.17 and minibb 1.7c successfully, i wanted to create a forum but after i tried to logon with my admin account i get an error message like this "The URL you asked for does not exist on this website".

I can create user accounts, access statics aso..

I searched the manual and looked up some support post here, but didn't find a clou to my problem.

- kerstin

Author MB
Guest
#2 | Posted: 11 Feb 2004 00:32 
Have you renamed the admin (bb_admin I think is its file name) file during setup? You will need to make sure the change is reflected in the setup_options file.

Just be sure your "physical" admin name (bb_admin.php by default) is specified in $bb_admin setting with the same file name + question sign at the end. For example, if you have

$bb_admin='renamed_admin_file.php?';

your admin script filename must be: renamed_admin_file.php

--MB

Author Team
8-)
#3 | Posted: 19 Apr 2005 11:16 | Edited by: Team 
Points to solution (A MUST-READ COLLECTION FOR EVERYONE HAVING THIS TROUBLE):

* Make sure you are entering login and password EXACTLY as you have specified in setup_options.php' $admin_usr and $admin_pwd - logins and passwords in miniBB are case sensitive. Be sure you have turned off CAPS button on your keyboard and set correct keyboard layout, if you are using more than one English language. For the first time, having this trouble, try to set EASY login and EASY password conatining only latin letters and digits, for example - because your browser could interpret special symbols incorrectly.

* Make sure you have set up COOKIE SETTING properly. You will find them all in setup_options.php Don't mess cookie domain (it should not begin with 'http://') with cookie path (in most cases, it is enough to set it to '/'). Contact your server administrator and ask him about cookie settings, if you are experiencing troubles. miniBB default cookie settings are common for most server configurations and should work automatically.

* Make sure your browser supports COOKIES enabled. For checking it, enter miniBB forums with anonymous name - simply type some nickname in "Login" field without password and press "Enter forums" button. If your nickname is KEPT and you see it in "Login" field after page refresh - your cookie ARE enabled normally. If you don't see your nickname - they are DISABLED. Please, enable them so they should work (in IE, go to Tools - Internet Options - Privacy - set at last Medium privacy).

* Make sure you have no spaces, newlines, empty symbols in setup_options.php file or any another PHP file you have edited - before <?php or after ?>. Cookie can not be set if some information is outputted before.

* On IIS servers (not Apache!), Location Headers may not work. It is just because some of IIS versions do not support them. You need to decomment $metaLocation='go'; setting in setup_options.php. I hope you know what does it mean - "decomment" = remove two slashes before that option

* It is a known issues where the problem is somewhere on your client side. Try to login with all possible browsers you have installed - Internet Explorer, Mozilla Firefox, Opera. If it works in Firefox, but doesn't work in IE, for exampe, the problem is your IE version. miniBB authorization is very native and needs to be supported by all latest versions of major browsers. Be sure you have the latest browser release installed, and your OS version is properly updated.

Author MWDomeier
Guest
#4 | Posted: 11 Nov 2004 16:32 
I checked the other threads with similar problems, but have not yet found a solution.


First, here's some information on my server that may be useful...
Operating system: Linux
Kernel version: 2.6.7-grsec
Machine Type: i686
PHP version: 4.3.9
MySQL version: 4.0.20-standard

I installed the latest version of miniBB according to the instructions on your website. Everything seemed to work properly. However, when I tried to login to the admin panel, it does not log me in. Instead it returned me to the login in page and told me, "You need to enter your admin login to view this area."

The top of the page also displays the three following warnings...

Warning: Cannot modify header information - headers already sent by (output started at /home/domeier/public_html/minibb/setup_options.php:101) in /home/domeier/public_html/minibb/GK_admin.php on line 116

Warning: Cannot modify header information - headers already sent by (output started at /home/domeier/public_html/minibb/setup_options.php:101) in /home/domeier/public_html/minibb/GK_admin.php on line 117

Warning: Cannot modify header information - headers already sent by (output started at /home/domeier/public_html/minibb/setup_options.php:101) in /home/domeier/public_html/minibb/GK_admin.php on line 120

I've double checked all my settings, and as far as I can tell everything is set properly.

Author Team
8-)
#5 | Posted: 11 Nov 2004 16:41 
MWDomeier
Remove empty newline or break in setup_options.php after ?>

Author MWDomeier
Guest
#6 | Posted: 11 Nov 2004 16:44 
Yep... There were a half dozen or so carriage returns at the end of the file. Removing them fixed the problem.

Thanks.

Author Team
8-)
#7 | Posted: 12 Nov 2004 03:17 
ok, cool

Author pompa
Guest
#8 | Posted: 10 Nov 2006 07:25 
> Remove empty newline or break in setup_options.php after ?>

COOOOOOOOOOOOOOOOLLLLLLLLLLLLLL !!!
Thanks Team

Author OMFG!!!
Guest
#9 | Posted: 17 Jun 2007 14:07 
* It is a known issues where the problem is somewhere on your client side. Try to login with all possible browsers you have installed - Internet Explorer, Mozilla Firefox, Opera. If it works in Firefox, but doesn't work in IE, for exampe, the problem is your IE version. miniBB authorization is very native and needs to be supported by all latest versions of major browsers. Be sure you have the latest browser release installed, and your OS version is properly updated.

OMFG I USED IE 7 (the last) and it dont works :(

Author Paul
Lead Developer
#10 | Posted: 19 Jun 2007 04:23 | Edited by: Paul 
I am using Internet Explorer 7.0.5730.11 as the latest from Windows updates, and everything works fine.

Make sure also you have a legal copy of Windows with all patches.

By the way, simply posting "it didn't work" is not the reason to claim the software. It is not clear what exactly does not work. Sounds lame.

Author Pyro529
Guest
#11 | Posted: 11 Jul 2007 17:16 
I had the same problem with the admin login.

What worked for me is I extracted the forum files again and edited all the setup_options.php again and it worked!

Author Anonymous
Guest
#12 | Posted: 27 Aug 2007 01:04 
Yep, I have the same problems though I configure everything per your suggestions, please help coz I do not have patience not more...

Tran

Author Paul
Lead Developer
#13 | Posted: 27 Aug 2007 13:05 | Edited by: Paul 
Tran: we have an open source free software with a free documentation, which actually means everything you do, is in your own hands.
If you have no ideas where the trouble comes from, you could hire us to investigate it for you.

Author yagga
Registered
#14 | Posted: 13 Jan 2014 16:13 
i am still having login problems.
i set my cookie to my domain WITHOUT the "h t t p //"
and i fill in my admin username and password.
But i keep getting the message: This area requires your Administrative account details. Please, sign-in!

did i forgot someting to edit? please help!

Author Paul
Lead Developer
#15 | Posted: 13 Jan 2014 21:14 
set $cookiedomain=''; do not set any value at first! Most likely you can leave this value as blank - this is what the manual suggests, now it appears YOU did make a change that was never requested! Not sure what else to suggest... could be tens of reasons. Like I explained above, for a small fee we could investigate and set it up for you, if you can't do it on your own.

FAQ miniBB Support Forums / FAQ / Admin Login problems Top

Your Reply Click this icon to move up to the quoted message

 Short link for this topic:

 ?
You are welcome to post anonymously, by entering a nickname with no password (if the similar Username has not been taken yet), or by leaving both fields empty. If you have a forums account, you can also sign in from this page without posting a message, or sign in and post at once.


Before posting, make sure your message is compliant with our forum posting rules. If not, it may be locked or deleted with no explanation.
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Install the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB