miniBB Support Forums | 15 years on The Web
miniBB ®

miniBB

®
 
 | Forums | Register | Search | Statistics | Manual |
Bugs miniBB Support Forums / Bugs /   
 

Quote solution does not work properly

 
 
Page  Page 1 of 2:  1  2  Next »

Author Moony
Partaker
#1 | Posted: 29 Aug 2005 14:40 | Edited by: Moony 
I have installed Quote Solution Plugin and have this problem:

When I edit post with a quote and save it, the quote bb-code messes up like this: [quote]<div class="quoting">Quoting: jyothi [/quote]It doesn't work properly</div>

It works on the developers site, so probably I have done something wrong.

Author cakeman
Partaker
#2 | Posted: 29 Aug 2005 14:59 
Well, can you you copy here your bbcode file ?

Author Moony
Partaker
#3 | Posted: 29 Aug 2005 15:05 
Sorry, fixed myself. Thanks for a very useful solution! I advice Team to integrate it into the main forum script.

Author cakeman
Partaker
#4 | Posted: 29 Aug 2005 15:09 
What was the error ?

I had it in the past but not remenber the cause

Author ragots
Partaker
#5 | Posted: 8 Nov 2005 11:28 
I tried and failed to have it work on my board.

I replaced all the codes as instructed but I still get the same old italics quotes.

Author Team
8-)
#6 | Posted: 8 Nov 2005 14:48 
Check the readme again. It works on our test version - that means it should work anywhere else, if you setup correctly.

Author Moony
Partaker
#7 | Posted: 4 Dec 2005 22:11 | Edited by: Moony 
I have encountered another problem with Quotes Solution by cakeman


I get quote messed up wneh it goes like this:

[quote=Moony]Moony: www.indostan.ru[/quote]

i.e. when inside quote tags there is ":" and url

Author Team
8-)
#8 | Posted: 5 Dec 2005 11:37 
Guess, it's not the quote solution bug, but the bug inside old miniBB parsing code. Will be updated in the next version... I've tested this on miniBB.test and it seems to be working.

Author Anonymous
Guest
#9 | Posted: 17 Jul 2006 10:19 
i'm sure i installed correctly, but post cell displays:

... USERNAME')" onMouseMove="pasteSel()">Quote ...

main_posts.html code is this:

function getQuotation(User) {
var bw=new checkBrowser();
var displayQuote={$displayQuote};
if (displayQuote && (bw.dom || bw.ns6 || bw.ie5 || bw.ie6 || bw.ns4 || bw.safari

|| bw.opr)) {
document.writeln('<a

href="javascript:paste_strinL(selektion,1,\'\',\'\',\'\',\'' + User + '\')"

onMouseMove="pasteSel()">{$l_quoting}<'+'/a>');
}
}


what's wrong with it?

Author Paul
Lead Developer
#10 | Posted: 17 Jul 2006 12:22 
There must be no newlines between code.

Author Anonymous
Guest
#11 | Posted: 17 Jul 2006 17:05 
there weren't actually any newlines, it just came out like that. but when i add apostrophes on either side of "User" the quote link displays properly but bb tag in the text box comes out as literally [quote=User]. go figure!

Author Anonymous
Guest
#12 | Posted: 17 Jul 2006 17:13 
this is what i see next to "edit" link

lutz')" onMouseMove="pasteSel()">Quote
^^ where username is link and everything else is not

if i mouse over the username link, in bottom left of the browser status bar the path is given as

javascript:paste_strinL(selektion,1,",",",'<a href=

Author Paul
Lead Developer
#13 | Posted: 18 Jul 2006 07:31 
Sorry, I can not suggest anything until I see the live page.

Author lutz
Partaker
#14 | Posted: 18 Jul 2006 15:06 
Ok, here's a link.

I implemented this Quotes solution on another miniBB forum I had and it worked fine! I promise I'm not just being stupid or anything...

Author Paul
Lead Developer
#15 | Posted: 18 Jul 2006 16:03 
You have some addon or additional code... or something more, which messed up $posterName variable.

I mean, in main_posts_cell.html, there is a code

<script type="text/javascript">getQuotation('{$posterName}');</script>

but if you check the final source, it becomes

<script type="text/javascript">getQuotation('<a href="http://voulezvous.po.gs/hs/forum/index.php?action=userinfo&amp;u ser=1" rel="nofollow">lutz</a>');</script>

which definitely is wrong...

Page  Page 1 of 2:  1  2  Next » 
Bugs miniBB Support Forums / Bugs /
 Quote solution does not work properly
 Share Topic's Link

This topic is closed. New replies are not allowed.

 
 
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contact Us
Proceed with the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
↑ TOP