miniBB ® miniBB®
miniBB Support Forums
 | Forums | Register | Search | Statistics | Manual |
Bugs miniBB Support Forums / Bugs /   

File Upload addon bug: when file's Name contains apostrophes

Author harootun
Registered
#1 | Posted: 23 Jun 2007 09:21 
The File Upload feature is VERY popular on my forum. But one thing I've noticed with the posts people make is that there are a number of them that don't pop up in a new window. Instead they appear in the same window as the forum, replacing the forum. It's odd because sometimes they'll post numerous pics in a post, and only one of the bunch won't pop up.

I could give numerous examples of this, but since my site is adult-ish, I didn't really want to put up a link. I can do it in private if someone wants to take a look.

Anyone else having this happen on their sites?

Author tom322
Registered
#2 | Posted: 23 Jun 2007 11:14 
I think if the image is smaller than specified in the options, the popup won't appear, and it makes sense (as users expect to see a bigger/original image in the pop up).

Author harootun
Registered
#3 | Posted: 23 Jun 2007 11:52 | Edited by: harootun 
I don't believe it is size related. In one post, a user put up two jpegs, both identically sized (540x570 pixels). One pops up. The other doesn't.

Author tom322
Registered
#4 | Posted: 23 Jun 2007 11:56 
You can put a link (inactive) to the post and it would be easier to check, I think..

Author Paul
Lead Developer
#5 | Posted: 25 Jun 2007 04:36 | Edited by: Paul 
harootun
Contact me privately, send a link and I'll take a look. I hope you know my email address.

You may also test it on minibb.org posting the same JPEGs (no problem if they will have adult content) - it could depend on the JPEG type which differ.

Author harootun
Registered
#6 | Posted: 25 Jun 2007 06:10 | Edited by: harootun 
Paul,

I put up three pics from my forum (non-adultish ones) onto the test forum here, and they're behaving the exact same way. The third one (furthest to the right) doesn't pop up. Or at least it doesn't in my browsers.

If you want more samples from my site, let me know and I'll email them to you.

Thanks!

Author tom322
Registered
#7 | Posted: 25 Jun 2007 09:32 
For me they all pop up (including the Straight off a '50s comic?) - on IE7 and Firefox..

Author Paul
Lead Developer
#8 | Posted: 25 Jun 2007 09:32 | Edited by: Paul 
It seems that issue appears when the "name of the file" i.e. description field contains apostrophes... I've fixed it and now it should work ok :-) Version 1.8.1 is already in the customers area... welcome to update and test.

The code to update is just for bb_plugins.php

tom322
It just seems you have tested it right away after I've fixed it :-)

Author tom322
Registered
#9 | Posted: 25 Jun 2007 10:01 
It just seems you have tested it right away after I've fixed it :-)
Yep, I think so (more testing on the way though..;).

Author harootun
Registered
#10 | Posted: 26 Jun 2007 05:42 
Thanks, Paul. Once again, amazingly fast fix! Very impressive!

Author Paul
Lead Developer
#11 | Posted: 26 Jun 2007 08:54 | Edited by: Paul 
Ok, thank you!

Bugs miniBB Support Forums / Bugs / File Upload addon bug: when file's Name contains apostrophes Top
This topic is closed. New replies are not allowed.
 
miniBB Support Forums Powered by Forum Software miniBB ® Features  Requirements  Demo  Download  Showcase  Gallery of Arts
Compiler  Premium Extensions  Premium Support  License  Contacts
Check out the Captcha add-on: protect your miniBB-forums from the automated spam and flood.
Captcha Addon for miniBB